PHP 5.6 and Why You Should Stop Using It

php56_stop_using

PHP 5.6 was a very good version of PHP and widely used. The PHP 5 branch enjoyed years of updates and was very popular with developers. However all good things must come to an end. As of Jan 1st, 2019, PHP 5.6 has reached E.O.L which means of end of line. This means it is no longer receiving security fixes.

What does this mean for you?

If you have been keeping your PHP applications up to date (you should be!) then moving to a new version of PHP will be no problem. PHP applications that are in a continual state of development will almost always be supporting the latest in technology. This is especially true for PHP applications. So you should be fine.

However we all live busy lives and we tend to forget about the applications we have installed to run our online website/applications. So they tend to get overlooked when it comes to updates. If you have not been keeping your PHP applications updated, then the first thing to do is check with the developer website to see if there are updates to the applications you are using. If there are newer versions of your application, then updating your application should be relatively straight forward. Many modern applications such as WordPress has an automated update process that makes it very easy to move your WordPress powered website to a newer version.

Regardless of where you are at, you have to understand that you must leave the use of PHP 5.6. Security vulnerabilities will eventually be found in it (if they haven’t already), and when they are, any application you have running on PHP 5.6 will be vulnerable and eventually compromised.

Why moving to PHP version 7.1 or higher is the right thing to do.

Speed!

PHP 7 saw a rewrite of the Zend Engine adding one of the most massive speed enhancements to PHP applications ever. PHP 7.1 and higher adds immense performance increases to php applications that were running on PHP 5. You want to see a dramatic increase in your WordPress site? Make sure it is running on PHP 7.1 or higher. It is that simple.

Code compatibility

New version of PHP applications will now be dropping support for PHP 5.6. That means you will not be able to upgrade your PHP 5.6 application to the latest version until you switch to you PHP 7.1. However doing so make break your existing, pre-updated, PHP application. In other words the transition stage of migrating PHP applications seamlessly from PHP 5 to PHP 7 is closing fast.

Security

PHP 7.1 and higher are still being maintained and updated. This includes bug fixes and security updates. So moving to PHP 7.1 will be the safe and secure thing to do. Running out of date PHP applications that are no longer receiving security patches puts our servers as risk. Please don’t do that. It is unfair to us and you.

How do I move to PHP 7.1 or higher?

Well that is the easy part! We have a nice cPanel tool called MultiPHP Manager. Just access that tool (located under the Software section of cPanel) to manage the PHP versions for your website and web applications. The tool will list all of the available PHP versions that we have installed on the server. We also have a detailed knowledgebase article on how to use the MultiPHP tool.

Motivated to move away from PHP 5.6?

Hopefully we have helped you to see the benefits of moving away from PHP 5.6. If you need your PHP applications updated so you can run a newer version of PHP then let us know and we will be happy to assist you in getting your PHP applications up to date. However please understand that we do not offer this service for free. We will review your needs and give you a fair and reasonable quote to do the upgrade.